Mandatory Zoom client updates starting in September

WHAT ARE WE DOING?
Due to upcoming Zoom-issued restrictions, Computing is implementing mandatory Zoom client updates starting in September. Users will be required to update their Zoom clients (Windows, Mac, iOS, Android, etc.) to the latest version at least every six months. However, we advise you to update your Zoom client more frequently. In the event of a critical security update, you will be required to update your client, potentially on short notice.

WHAT IS THE IMPACT TO YOU?
If you haven’t updated your Zoom client by Sept. 1, you will be prompted to do so when you try to start or join a Zoom meeting, which may delay your meeting. We advise you to update your Zoom client before your scheduled meetings to avoid any inconvenience.

WHAT DO YOU NEED TO DO?
Before Sept. 1, your Zoom client should be updated to version 5.7.4 or higher.

How to CHECK your Zoom client version: https://fermi.servicenowservices.com/kb_view.do?sysparm_article=KB0013423.

How to UPDATE your Zoom client version: https://fermi.servicenowservices.com/kb_view.do?sysparm_article=KB0013424.

 

Are you unable to update via your Zoom client? Try these alternatives:

Windows Software Center: https://fermi.servicenowservices.com/kb_view.do?sysparm_article=KB0011983.

Mac Self Service: https://fermi.servicenowservices.com/kb_view.do?sysparm_article=KB0011690.